L’environnement « develop » de WordPress a dernièrement évolué pour améliorer la modularité et la flexibilité de ses JavaScripts, préparer l’arrivée prochaine de l’éditeur du projet Gutenberg et favoriser le recours aux pratiques JavaScript modernes. Je vous invite à prendre connaissance de l’article ci-dessous pour en savoir plus sur le sujet.

Poursuivre la lecture de « Build oblige, les extensions s’insèrent symboliquement »

La prochaine version majeure de WordPress, la 5.0.0, est dépendante des progrès accomplis concernant l’intégration du projet Gutenberg (contenant notamment l’éditeur moderne). En attendant, les versions mineures à venir peuvent être amenées à intégrer de nouvelles fonctionnalités et ne sont plus seulement des versions de maintenance ou de sécurité. Voici une situation problématique, qui je l’espère perdurera le moins longtemps possible.

Poursuivre la lecture de « 4.9.6 une version mineure de #WordPress à risques. »

Que vous soyez développeur de plugins ou designer de thèmes WordPress, développeur de plugins ou designer de thèmes BuddyPress, professionnel spécialisé WordPress (freelance ou travaillant dans une SS2I), administrateur technique ou encore membre d’une communauté motorisée par BuddyPress, vos rapports de bug, vos propositions de correctif ou d’évolution, ou plus globalement toutes vos contributions au projet BuddyPress sont les bienvenues.

Poursuivre la lecture de « Contribuez à BuddyPress : testez et proposez des patchs ! »